Troubleshooting
KB N°2780

Services Olfeo indisponibles au démarrage de la VM (alerte "/proc not mounted" dans le chroot)

Version: V6.x
Publié le lundi 3 juin 2019
Modifié le lundi 10 juin 2019

Services indisponibles au démarrage (alerte "/proc not mounted")

                                                                                CONTEXTE

 

Le phénomène ci-dessous se manifeste uniquement sur des VM.

Vos services ne sont pas démarrés et le message "/proc not mounted" apparaît lorsque vous faites un contrôle des services Olfeo via un /olfeo-status.sh

                                                                                   ÉTAPES

    

Un des services Olfeo peut mettre trop de temps a démarrer et de générer cette erreur suite à un timeout de l'Olfeo-Chroot paramétré par défaut sur 3min.

La solution est d'augmenter ce timeout.

Pour se faire, editer ce fichier (hors chroot):

vim /lib/systemd/system/olfeo-chroot.service

<code>
[Unit]
Description=Olfeo chroot
Documentation=http://support.olfeo.com/

Requires=opt-olfeo-chroot-dev.mount opt-olfeo-chroot-proc.mount
After=opt-olfeo-chroot-dev.mount opt-olfeo-chroot-proc.mount

[Install]
WantedBy=default.target

[Service]
Type=forking
ExecStart=/olfeo-chroot-start.sh
ExecStop=/olfeo-chroot-stop.sh

RootDirectory=/opt/olfeo/chroot
EnvironmentFile=/opt/olfeo/chroot/etc/environment

TimeoutSec=3m

<code>

Modifier la valeur TimeoutSec et la passer à 10mn.

Esc :wq! pour quitter et sauvegarder le fichier.

                                                                               VALIDATION

Redémarrer la VM, via la commande mount (hors chroot) vous pourrez trouver cette ligne /proc on /opt/olfeo/chroot/proc qui signifie que l'Olfeo chroot est monté.

 

 

Avez-vous trouvé cet article utile ?
Revenir à la liste des articles
En visitant ce site, vous acceptez l'utilisation de cookies. Nous utilisons des cookies pour améliorer votre navigation sur notre site. En savoir plus.Ok